Language Selection

English French German Italian Portuguese Spanish

KDE4 and Plasma 5 for Slackware

Filed under
KDE
Slack
  • KDE4 and Qt4 deprecation in FreeBSD

    This is a reminder — for those who don’t read all of the FreeBSD mailing lists — that KDE4 is marked deprecated in the official ports tree for FreeBSD, and will be removed at the end of this year (in about 20 days). Then Qt4 will be removed from the official ports tree in mid-march.

    Since both pieces of software are end-of-life and unmaintained upstream already for several years, the kde@ team at FreeBSD no longer can maintain them. Recent time-sinks were dealing with OpenSSL 1.1.1, libressl, C++17, .. the code is old, and there’s newer, nicer, better-maintained code available generally by replacing 4 with 5.

  • KDE Plasma 5 for Slackware – end of the year edition

    I just uploaded a whole new batch of packages containing KDE Plasma5 for Slackware. The previous batch, KDE 5_18.10 is already two months old and has some library compatibility issues. The new KDE 5_18.12 for Slackware consists of KDE Frameworks 5.53.0, Plasma 5.14.4 and Applications 18.08.3. All this on top of Qt 5.11.3.
    Compiled on the latest Slackware -current, it’s running smoothly here on my laptop.
    I decided against upgrading to QT 5.12.0. This is a new LTS release, but I will wait for the other distros to find bugs in this new software. Next week, KDE will release KDE Applications 18.12.0 and that too is something I want to check a bit before releasing Slackware packages. Therefore it’s likely that a new batch of packages containing Qt 5.12 and KDE Applications 18.12 will see the light shortly after the New Year.

More in Tux Machines

today's howtos

Android Leftovers

Dillo: Does This Ultra-Lightweight Browser Still Work in 2020?

Before jumping in, you should know exactly what Dillo doesn’t include, just to temper your expectations. Dillo does not include Flash, Java, or Javascript and only has limited support for frames. It also doesn’t allow you to create a user profile. Presumably, that will be most of the modern Internet out of the picture, but who knows? We’ll see. The advantage of all that feature-cutting is that it will run on almost anything – even a 486 with dial-up Internet. Running at idle, Dillo was using 2.9 MB of RAM and 9.5 MB of shared memory, which is microscopic compared to the gigs of RAM used by modern browsers. If you’re willing to trawl the Internet, people have run it on Mac, DOS, and a bunch of Unix variants, but now the website just has source tarballs, mostly focusing on Linux. It can also run on Windows, but the Dillo team actively dislikes the platform! Read more

Will LibreOffice 7.0 be only Personal Edition for individual use???

Look at LibreOffice logo with "Personal Edition" phrase, look at sidebar in Start Center with the same phrase and note to "The Personal edition is supported by volunteers and intended for individual use." And what is mean? Where is any public announcement? They say it was in marketing mail list. How many people read that mail list? Five? It means that I can't install LibreOffice 7.0 in any organization in Russia, because our controlling people will be see very simple to legality in this case: open the About dialog -> read that "intended for individual use" and LibreOffice logo with "Personal Edition" -> you can't use LibreOffice here! Nobody will check what say MPL 2.0 license about it or why TDF made it, they just point a finger at it and they will be right! It will close for LibreOffice any education organizations like schools or colleges or universities. I wont popularize LibreOffice for young people because they will never see LibreOffice in them schools. I against these changes. Please revoke it! Read more