Install Gentoo Portage on non-Gentoo Distribution

Filed under
HowTos

Requires Python >= 2.2.x and Development Packages (gcc, binutils, automake, autoconf, libtool, gawk, mawk, bison). Make sure your current distro installed with above packages. If not, use apt-get or yum to install it. Make sure you have enough space in /.

Login as root and save the following script in / as xanda-portage.sh

Then run the following command to run the script

# chmod 777 xanda-portage.sh
# ./xanda-portage.sh

More Here