Language Selection

English French German Italian Portuguese Spanish

Changelog.i386 Beta 3

------------------------------------------------------------------
--- Changelog.i386 ---------- Wed Aug 24 15:17:14 CEST 2005 ------
------------------------------------------------------------------
------------------------------------------------------------------
------------------ 2005-8-24 - Aug 24 2005 -------------------
------------------------------------------------------------------

++++ hwinfo:

- fix pppoe detection (#106836)

++++ yast2-installation:

- fixed umount_result setting in /etc/install.inf. A space is
needed between the colon and the value (#112620)

------------------------------------------------------------------
------------------ 2005-8-23 - Aug 23 2005 -------------------
------------------------------------------------------------------

++++ aaa_base:

- Complete comment about force-reload in init.d/skeleton

++++ autoyast2:

- fix for compatibility with new storage lib
(wipe out partition table was broken)
- Documentation update
- 2.12.12

++++ bluez-utils:

- fixed path in diff for moved testX and wrong path on
x86_64 [#106628]

++++ gdm:

- Update to version 2.8.0.3
- Remove upstreamed autologin patch
- Now installs .desktop files in correct location no need to move

++++ gnome-desktop:

- Update to version 2.11.92

++++ gnome-icon-theme:

- Update to version 2.11.92

++++ gnome-spell2:

- removed control-center from nfb and added dirs instead
to break up build-dep cycle

++++ ipod-sharp:

- added check-build.sh

++++ kernel-update-tool:

- Initial release.

++++ master-boot-code:

- Added FixCHS to fix C/H/S geometry in MBR (#103031)

++++ sysvinit:

- Enable patch for killproc

++++ xinetd:

- added logrotate to Requires

++++ yast2-installation:

- fixed umount call in First-Stage setup -> added F03-umount (#103800)
- mark correct tab selected after language is changed (#105995)
- reset target map when switching between installation and upgrade
(#106627)

------------------------------------------------------------------
------------------ 2005-8-22 - Aug 22 2005 -------------------
------------------------------------------------------------------

++++ MozillaFirefox:

- install gconf schema for lockdown also on non-NLD
- added backports (firefox-backports.patch)
* gtk_im_context_set_cursor_location() is not used (bmo #281339)
* fixed crash in imgCacheValidator::OnStartRequest()
(bmo #293307)
- workaround for linking with pangoxft and pangox
(broken by gtk 2.8 update) (#105764)
- remove extensions on deinstallation
- include dragonegg (kparts) plugin (#105468)

++++ aaa_skel:

- skel/Documents to 700 (#106004)

++++ amavisd-new:

- update to version 2.3.3

++++ apache2-mod_ruby:

- added ruby-devel to nfb

++++ banshee:

- Fix exe.config.in again so that it will actually run.
- Update to version 0.8.7.1
- Split out -engine-gst and -engine-helix packages from banshee
- Add gnome-vfs2 to nfb

++++ beagle:

- Disable autostart in KDE

++++ bluez-utils:

- renamed bluetooth_udev.sh to udev.bluetooth.sh to have unique
namingscheme [requested by hotplug-group]
- minor fixes in udev.bluetooth.sh

++++ bootsplash-theme-SuSE:

- use real prelim of non-silent graphics

++++ bzflag:

- fix data type comparison [Bug #104607]

++++ control-center2:

- Update to 2.11.92
- Remove upstreamed theme-thumbnail patch
- added pangoxft to liblist

++++ cups-drivers:

- removed unwished PS printers from Ricoh and affiliate (bugzilla#106080)

++++ deltarpm:

- update to deltarpm-3.1

++++ ebview:

- added libpango_x to liblist

++++ eog:

- Update to version 2.11.92

++++ evms:

- add so-link to /usr/lib

++++ evolution-webcal:

- Update to version 2.4.0

++++ f-spot:

- Update to version 0.1.1
- Add f-spot-import script for g-v-m support
- Fix crashes (b.g.o 313850)
- Fix lockup in import dialog

++++ file-roller:

- Update to version 2.11.92
- Add libxml2 and libxml2-python to nfb

++++ gcalctool:

- Update to version 5.6.28

++++ gconf2:

- Update to version 2.11.92

++++ gfxboot:

- new translations
- prepare for jpeg decompression to 8-bit color space
- add penguin theme
- Dansk keymap added

++++ gnome-applets:

- added libpangoxft to liblist

++++ gnome-games:

- Update to version 2.11.5

++++ gnome-panel:

- Update to version 2.11.92
- remove control-center2 from nfb

++++ gnome-pilot:

- removed control-center2 from nfb

++++ gnome-session:

- Update path to autostart NetworkManager applet in new location

++++ gnome-speech:

- Add festival to requirements (8871).

++++ gnome-volume-manager:

- Update schema to launch f-spot-import script

++++ gnutls:

- fix data type comparison [Bug #104617]

++++ groff:

- Bugzilla #105807: /etc/papersize can be changed by SuSEconfig,
don't verify md5, size, mtime.
/usr/share/groff/1.18.1/tmac/mm/locale and
/usr/share/groff/1.18.1/tmac/mm/se_locale are empty by default,
don't verify md5.

++++ hal:

* updated to new cvs version (pre0.5.4)
- removed upstream gone patches:
* hal-fix-usb_pda_palm_hotsync.diff
* hal-fix-util.c_percentage.diff
* hal-fix-configure_for_translations.diff
- added patches:
* hal-fix-ACPI_seqfault.diff
* hal-add-advanced_medium_detect.diff (patch from ervin@kde.org
and fixed/reworked by dkukawka@suse.de)

++++ hostap:

- hostap-driver: update to 0.4.4, changes:
* added support for pcmcia changes in Linux 2.6.13
* added support for creating sysfs device files (Linux 2.6.x)
* fixed power save processing for PS-Poll frames with PwrMgmt flag
set (this was causing "wifi0: invalid skb->cb magic" errors)
* fixed linking both hostap_cs and hostap_pci to kernel
* filter out sequential disconnect events to make race condition with
received EAPOL frames less likely to happen (this improves
authentication success rate with some APs that send EAPOL frames
very quickly after the (re)association response)
* added support for setting channel mask for scan requests

++++ hwinfo:

- fix pcmcia controller detection

++++ imap:

- the FreeFork license used by UW says we have to make it clear in the version
number that we modified the sources; hinted by our license manager

++++ ipod-sharp:

- Update to version 0.5.1 needed by banshee update

++++ kdeaddons3:

- update to 3.4 branch

++++ kdebase3:

- Use --embed-proxy instead of --embed for kcmshell with kcmyast,
so that there are no kcmshell buttons with embedded yast.
- Don't start kaccess unconditionally.
- fixed file list
- fix file conflict

++++ kdebase3-SuSE:

- update from SVN (kcmyast part of fixes for #46495)
- update from SVN

++++ kdeedu3:

- update to 3.4 branch

++++ kdegames3:

- update 3.4 branch

++++ kdegraphics3:

- update 3.4 branch (kpdf fixes, #99663)
- added directory to filelist

++++ kdelibs3:

- don't put libkdeinit_*.so in -devel

++++ kdesdk3:

- callgrind should invoke valgrind2 (#106064)

++++ kdeutils3:

- added directory to filelist

++++ kernel-bigsmp:

- series.conf: Disable barriers by default...
- patches.suse/usagi-ipv6-ip6t-reject: forward ported ip6t_REJECT (105561)
and re-enabled it.
- Update config files.
- Update xen patches to hg-6315.
- Move xen/linux public headers to userspace package.
- add sky2.patch new driver for Marvell Yukon 2 chipset
- rpm/kernel-binary.spec.in: remove -override- module path.
- Update iscsitarget to svn r1247.
- Update configs.

++++ kernel-default:

- series.conf: Disable barriers by default...
- patches.suse/usagi-ipv6-ip6t-reject: forward ported ip6t_REJECT (105561)
and re-enabled it.
- Update config files.
- Update xen patches to hg-6315.
- Move xen/linux public headers to userspace package.
- add sky2.patch new driver for Marvell Yukon 2 chipset
- rpm/kernel-binary.spec.in: remove -override- module path.
- Update iscsitarget to svn r1247.
- Update configs.

++++ kernel-smp:

- series.conf: Disable barriers by default...
- patches.suse/usagi-ipv6-ip6t-reject: forward ported ip6t_REJECT (105561)
and re-enabled it.
- Update config files.
- Update xen patches to hg-6315.
- Move xen/linux public headers to userspace package.
- add sky2.patch new driver for Marvell Yukon 2 chipset
- rpm/kernel-binary.spec.in: remove -override- module path.
- Update iscsitarget to svn r1247.
- Update configs.

++++ kernel-source:

- series.conf: Disable barriers by default...
- patches.suse/usagi-ipv6-ip6t-reject: forward ported ip6t_REJECT (105561)
and re-enabled it.
- Update config files.
- Update xen patches to hg-6315.
- Move xen/linux public headers to userspace package.
- add sky2.patch new driver for Marvell Yukon 2 chipset
- rpm/kernel-binary.spec.in: remove -override- module path.
- Update iscsitarget to svn r1247.
- Update configs.

++++ kernel-um:

- series.conf: Disable barriers by default...
- patches.suse/usagi-ipv6-ip6t-reject: forward ported ip6t_REJECT (105561)
and re-enabled it.
- Update config files.
- Update xen patches to hg-6315.
- Move xen/linux public headers to userspace package.
- add sky2.patch new driver for Marvell Yukon 2 chipset
- rpm/kernel-binary.spec.in: remove -override- module path.
- Update iscsitarget to svn r1247.
- Update configs.

++++ kernel-xen:

- series.conf: Disable barriers by default...
- patches.suse/usagi-ipv6-ip6t-reject: forward ported ip6t_REJECT (105561)
and re-enabled it.
- Update config files.
- Update xen patches to hg-6315.
- Move xen/linux public headers to userspace package.
- add sky2.patch new driver for Marvell Yukon 2 chipset
- rpm/kernel-binary.spec.in: remove -override- module path.
- Update iscsitarget to svn r1247.
- Update configs.

++++ kpowersave:

- fixed bug #105555
- updated translations

++++ kscpm:

- added new translations and updated existing ones

++++ libbonobo:

- Update to version 2.10.1

++++ libbonoboui:

- Update to version 2.10.1

++++ libgnomedb:

- removed control-center2 from nfb

++++ libipoddevice:

- Update to version 0.2.7 needed by banshee update.

++++ libsoup:

- Update to released 2.2.6.1 which includes the cvs patches we were already
folding in plus the second part of the fix for 104319

++++ libwnck:

- Update to version 2.11.92

++++ manufacturer-PPDs:

- Mark the Ricoh family PCLXL PPDs to be "(recommended)"
so that YaST selects them preferred because those models
do not understand PostScript by default but only optionally.

++++ mlterm:

- Bugzilla #105320: use libutempter again.

++++ openslp:

- also listen on SLPv1 General Multicast address [#64138]
- use poll instead of select [#65673]

++++ openssh:

- fixed problem when multiple accounts have same UID [#104773]
(pwname-home.diff)
- added fixes from upstream (upstream_fixes.diff)

++++ pam-modules:

- pam_mktemp updated (version 1.0.1)
- Added de es fr it ja nb pt_BR zh* translations

++++ pcmciautils:

- added cis files to package, install them to /lib/firmware
- added hwup function files
- changed /etc/hotplug/*rc: they call now hwup directly
- replaced *agent with hwup
- added /etc/sysconfig/pcmcia

++++ picfolio:

- Increase buffer, jpegs of todays cameras are bigger then 1MB

++++ pin:

- fixed bug #104800

++++ preload:

- reworked majorly

++++ privoxy:

- limit the debug
(privoxy shouldn't log all URLs by default - #99710)

++++ ruby:

- disabled mkmf patch for now. it breaks building the socket
extension.

++++ sane:

- Updated the hpaio.desc file according to our current HPLIP
software version 0.9.4.

++++ scpm:

- scpm lives now in /usr/sbin [#106246].
- added new translations for ja nb pt pt_BR zh_CN zh_TW
- updated existing translations

++++ scsi:

- Update to scsidev-2.36:
* Use SG_IO if available.
* Parse 2.6 kernel sysfs tape info.
* Better parse 0x83 VPD page.

++++ sumf:

- added new translations for ja pt_BR zh_CN zh_TW
- updated translations
- added start script which checks for necessity of kdesu
(bug 105114)
- using profile_chooser icon as KDE menu icon (bug 105111)

++++ sysconfig:

version 0.40.1
- rcnetwork:
+ make 'status' work again (broken since version 0.33)
+ 'reload' does nothing if network was not started
(both are related to bug 106040)
- ifup-wireless:
fixed print_key function for hex keys (bug 106051)
using new log message functions
added support for WEP keys up to 232 bit when entered as ASCII
- new version 0.40.0
- Changed hwup:
+ prepared removal of getcfg
+ restructured first part of hwup that collects information. It
checks the subsystem and calls specific subsystem functions if
these are defined. These may be defined in functions..
+ it now uses new output functions which respect udev loglevel.
+ allow spaces in config file names. Yes, ugly, but pcmcia may need it.
- added functions.susbsystem.template
- Add new config variable LOG_LEVEL and mark DEBUG as deprecated in
hardware/config. Backward compliance: DEBUG==yes ==> LOG_LEVEL=7
- Also change default of USE_SYSLOG to "no".
- removed FAILURE_ACTION completely, we will never use that

++++ sysvinit:

- Avoid zombie processes using startpar to get the next free
process slot as fast as possible.
- Make killproc be compliant with the newest LSB specs in case if
the specified pid file does not exist that the daemon is not
running (bug #105845).
- Add the possibility of using pid numbers instead of a pid file.

++++ udev:

- Removed all occurences of /etc/hotplug/functions from udev scripts
- Moved isdn.sh and firmware.hotplug.sh to /sbin/udev.*.sh
- Added README.Logging and a helper script to docdir
- Version 068git20050822
Fix some exit codes and a vol_id segfault

++++ util-linux:

- Fix rpm verify output [#105807]
(ghost entry for /var/lib/nfs/state)
- Fix stupid buffer overflow bug in cfdisk [#66020].

++++ vdr:

- relax init script dependencies and don't start dvb script from within runvdr
by default to make the package budget card friendlier (#106054)

++++ xaos:

- added icon [#106118]

++++ xen:

- Update to hg 6315.
- Include linux-public headers in xen-devel package.

++++ yast2:

- added check for `cancel to ncurses menu loop (#105507)
- 2.12.24

++++ yast2-bootloader:

- fixed creating new boot loader sections (#105668)
- 2.12.21

++++ yast2-country:

- earlier check for possible local time during installation (#104868)
- 2.12.13

++++ yast2-installation:

- fixed title icons for proposal dialogs (#105165)
- 2.12.22

++++ yast2-network:

- Don't use rcnetwork reload if it is not running (#106040).
- Don't stop network unnecessarily (Detection stuff, #106040).
- 2.12.12

++++ yast2-packager:

- removed XEN dirinstall client (obsoleted by yast2-vm - full
installation inside XEN VM) (#105831)
- 2.12.24
- do not put ACPI modules to initrd on architectures which do not
support ACPI (#105997)

++++ yast2-storage:

- add /boot as possible mount point if raid type is "raid1" (#105718)
- make checks for partition table consistenc less strict (#105612)
- make changes needed for Compaq CCISS controllers (#105514)
- fix bug preventing LVM over MD from working (#105728)
- 2.12.22

++++ yast2-trans-da:

- Update to version 2.12.2.
- Update to version 2.12.1.

++++ yast2-trans-nb:

- Update to version 2.12.2.

++++ yast2-tv:

- edit or delete just manually configured TV card (#106092)
- 2.12.4

------------------------------------------------------------------
------------------ 2005-8-21 - Aug 21 2005 -------------------
------------------------------------------------------------------

++++ banshee:

- added fam to nfb

++++ blam:

- added check-build.sh

++++ gdb:

- Add DWARF CFI unwinder on ppc.

++++ kdeaccessibility3:

- fix file list

++++ kdebase3:

- fix the kdm change for incomplete themes

++++ kdebase3-SuSE:

- another update for icons

++++ kdelibs3:

- update from 3.4 branch to fix endless kio_http loop
- fix DPMS check in admin (broke with --enable-new-ldflags)

++++ kernel-bigsmp:

- Update Xen patches to hg-6305.
- Fix overlapping link segments on xen x86-64.
- update patches.suse/suse-ppc-legacy-io.patch
disable 8250 if booted via BootX
- add patches.arch/ppc32-cflags.patch
compile with -mcpu=powerpc to remove all nops
- update patches.suse/suse-ppc-legacy-io.patch
disable isapnp in pmac setup to hide a warning
- update to 2.6.13-rc6-git13, network fixes
- Update Xen patches to hg-6299.

++++ kernel-default:

- Update Xen patches to hg-6305.
- Fix overlapping link segments on xen x86-64.
- update patches.suse/suse-ppc-legacy-io.patch
disable 8250 if booted via BootX
- add patches.arch/ppc32-cflags.patch
compile with -mcpu=powerpc to remove all nops
- update patches.suse/suse-ppc-legacy-io.patch
disable isapnp in pmac setup to hide a warning
- update to 2.6.13-rc6-git13, network fixes
- Update Xen patches to hg-6299.

++++ kernel-smp:

- Update Xen patches to hg-6305.
- Fix overlapping link segments on xen x86-64.
- update patches.suse/suse-ppc-legacy-io.patch
disable 8250 if booted via BootX
- add patches.arch/ppc32-cflags.patch
compile with -mcpu=powerpc to remove all nops
- update patches.suse/suse-ppc-legacy-io.patch
disable isapnp in pmac setup to hide a warning
- update to 2.6.13-rc6-git13, network fixes
- Update Xen patches to hg-6299.

++++ kernel-source:

- Update Xen patches to hg-6305.
- Fix overlapping link segments on xen x86-64.
- update patches.suse/suse-ppc-legacy-io.patch
disable 8250 if booted via BootX
- add patches.arch/ppc32-cflags.patch
compile with -mcpu=powerpc to remove all nops
- update patches.suse/suse-ppc-legacy-io.patch
disable isapnp in pmac setup to hide a warning
- update to 2.6.13-rc6-git13, network fixes
- Update Xen patches to hg-6299.

++++ kernel-um:

- Update Xen patches to hg-6305.
- Fix overlapping link segments on xen x86-64.
- update patches.suse/suse-ppc-legacy-io.patch
disable 8250 if booted via BootX
- add patches.arch/ppc32-cflags.patch
compile with -mcpu=powerpc to remove all nops
- update patches.suse/suse-ppc-legacy-io.patch
disable isapnp in pmac setup to hide a warning
- update to 2.6.13-rc6-git13, network fixes
- Update Xen patches to hg-6299.

++++ kernel-xen:

- Update Xen patches to hg-6305.
- Fix overlapping link segments on xen x86-64.
- update patches.suse/suse-ppc-legacy-io.patch
disable 8250 if booted via BootX
- add patches.arch/ppc32-cflags.patch
compile with -mcpu=powerpc to remove all nops
- update patches.suse/suse-ppc-legacy-io.patch
disable isapnp in pmac setup to hide a warning
- update to 2.6.13-rc6-git13, network fixes
- Update Xen patches to hg-6299.

++++ ruby:

- added directories to filelist
- fix typo in filelist

++++ valgrind:

- fix trace-children=yes failure
- add default suppressions for SL 10

++++ xen:

- Update to hg 6305.
- Update to hg 6299.
- Enable VNC support (depending on LibVNCServer).
- Split off xen-tools-ioemu for supporting unmodified guests.

++++ xfsprogs:

- no .a/.la files in /

------------------------------------------------------------------
------------------ 2005-8-20 - Aug 20 2005 -------------------
------------------------------------------------------------------

++++ SDL_perl:

- added SDL_mixer-devel + libmikmod to #neededforbuild, which
enables SDL_mixer support again --> fixes sound support in
frozen-bubble (Bug #106012)

++++ alsa-firmware:

- Don't require hotplug.

++++ samba:

- Update to 3.0.20.

++++ fontconfig:

- Bugzilla #105990: switch on embedded bitmaps again during
the installation.

++++ gdm:

- Make the default session option work on autologin; we now get GNOME.

++++ hal:

- added patch:
- hal-fix-hybrid_CDs.diff (fix for bug #105643)
* updated to current cvs version (pre0.5.4)
- added patches:
- hal-fix-usb_pda_palm_hotsync.diff (bug #104426)
- hal-fix-util.c_percentage.diff
- hal-fix-configure_for_translations.diff (fix to get all
localisations in the rpm)
- fixed bug #105285 removed /etc/dev/* from spec file

++++ kdebase3:

- trying to please Rudi's impatience (again saving
share holder value)
- some icons massage

++++ kdebase3-SuSE:

- update from SVN

++++ kdelibs3:

- update from 3.4 branch
- pleasing the libtool check

++++ kernel-bigsmp:

- Refresh Xen patch: include xen drivers in Makefile.
- update to 2.6.13-rc6-git12, follow_symlink, tg3, x86_64, nfs4 fixes
- Disable OCFS2 on ia64 as it doesn't build.
- patches.suse/ocfs2-configfs: OCFS2 and configfs merge.
- Regenerate Xen sparse patch.
- Further fixups for Xen on x86-64 (Jan).
- Enable Xen on x86_64 and fix compilation issues (Jan).
- Network drivers were missing from xen kernels: fixed.

++++ kernel-default:

- Refresh Xen patch: include xen drivers in Makefile.
- update to 2.6.13-rc6-git12, follow_symlink, tg3, x86_64, nfs4 fixes
- Disable OCFS2 on ia64 as it doesn't build.
- patches.suse/ocfs2-configfs: OCFS2 and configfs merge.
- Regenerate Xen sparse patch.
- Further fixups for Xen on x86-64 (Jan).
- Enable Xen on x86_64 and fix compilation issues (Jan).
- Network drivers were missing from xen kernels: fixed.

++++ kernel-smp:

- Refresh Xen patch: include xen drivers in Makefile.
- update to 2.6.13-rc6-git12, follow_symlink, tg3, x86_64, nfs4 fixes
- Disable OCFS2 on ia64 as it doesn't build.
- patches.suse/ocfs2-configfs: OCFS2 and configfs merge.
- Regenerate Xen sparse patch.
- Further fixups for Xen on x86-64 (Jan).
- Enable Xen on x86_64 and fix compilation issues (Jan).
- Network drivers were missing from xen kernels: fixed.

++++ kernel-source:

- Refresh Xen patch: include xen drivers in Makefile.
- update to 2.6.13-rc6-git12, follow_symlink, tg3, x86_64, nfs4 fixes
- Disable OCFS2 on ia64 as it doesn't build.
- patches.suse/ocfs2-configfs: OCFS2 and configfs merge.
- Regenerate Xen sparse patch.
- Further fixups for Xen on x86-64 (Jan).
- Enable Xen on x86_64 and fix compilation issues (Jan).
- Network drivers were missing from xen kernels: fixed.

++++ kernel-um:

- Refresh Xen patch: include xen drivers in Makefile.
- update to 2.6.13-rc6-git12, follow_symlink, tg3, x86_64, nfs4 fixes
- Disable OCFS2 on ia64 as it doesn't build.
- patches.suse/ocfs2-configfs: OCFS2 and configfs merge.
- Regenerate Xen sparse patch.
- Further fixups for Xen on x86-64 (Jan).
- Enable Xen on x86_64 and fix compilation issues (Jan).
- Network drivers were missing from xen kernels: fixed.

++++ kernel-xen:

- Refresh Xen patch: include xen drivers in Makefile.
- update to 2.6.13-rc6-git12, follow_symlink, tg3, x86_64, nfs4 fixes
- Disable OCFS2 on ia64 as it doesn't build.
- patches.suse/ocfs2-configfs: OCFS2 and configfs merge.
- Regenerate Xen sparse patch.
- Further fixups for Xen on x86-64 (Jan).
- Enable Xen on x86_64 and fix compilation issues (Jan).
- Network drivers were missing from xen kernels: fixed.

++++ libgphoto2:

- Don't require hotplug.

++++ submount:

- workaround for bug #94936. Added also "storage.mount_point" and
"storage.fstype"

++++ xen:

- Enable pygrub (at the cost of depending on e2fsprogs-devel)
- Enable VMX ioemu SDL support (at the cost of many dependencies)

++++ xkeyboard-config:

- updated to current CVS release (2005-08-20)
* updated Iranian layout to new standard (fd.o Bug #4102)
* updated translations for tr

------------------------------------------------------------------
------------------ 2005-8-19 - Aug 19 2005 -------------------
------------------------------------------------------------------

++++ FreeNX:

- freenx-0.4.4.diff:
* fixed nxsetup, when nx user does not exist yet

++++ aaa_base:

- Make sure that we really have /sbin in path even (bug #105681)

++++ acl:

- Move devel files from / to /usr
- Don't generate filelist dynamic (fix broken attr statements)

++++ amarok:

- fixed filelist

++++ attr:

- Move devel files from / to /usr
- Don't generate filelist dynamic (fix broken attr statements)

++++ autoyast2:

- pdf documentation added
- compatibility fix for new storage library
- UI shows the name of the current profile
- 2.12.11

++++ beagle:

- Update to version 0.0.13.1
- Remove upstreamed patches
- Now requires gtk-sharp2 and gecko-sharp-2.0
- Fix autostart (102606)
- Add galago-sharp to requires (105722)

++++ blam:

- Fix requirements (105907).

++++ compat-libstdc++:

- Build from sources [blocker #100149].
- Add cpp-fix-gcc4.diff.

++++ control-center2:

- Fix theme-thumbnail

++++ cracklib:

- Add Novell Tier1 translations

++++ desktop-data-SuSE:

- bump version to 10.0

++++ digikam:

- update to version 0.7.4
* translation updates
- fix file list for icons

++++ digikamimageplugins:

- update to version 0.7.4
* translation updates

++++ evms:

- move static lib to /usr/lib

++++ evolution-sharp:

- Update to version 0.9.1
- Require gtk-sharp2

++++ f-spot:

- Fix requirements to use gtk-sharp2, rather than gtk-sharp

++++ fontconfig:

- Bugzilla #105626: work around the loss of rendering quality
for the IPA fonts caused by the update to freetype 2.1.10 by
switching off the hinting for the IPA fonts.

++++ gedit:

- gedit-goto-line.patch to fix bugzilla.novell.com defect#6582

++++ glibc:

- Fix comment.
- Change .note.SuSE format [#105825].

++++ gmime:

- Updated to version 2.1.16
- Require gtk-sharp2

++++ gnome-applets:

- Use gnomesu instead of kdesu.

++++ gnome-panel:

- Fix to change to gnomesu to use /sbin/yast2

++++ gnome-session:

- Update to blue splash screen coloring

++++ gnome2-SuSE:

- Update to blue splash coloring

++++ gsf-sharp:

- Update to version 0.4
- Require gtk-sharp2

++++ gstreamer-plugins:

- Prereq fam to fix build of packages requiring default plugins

++++ gthumb:

- Added portait web sizes patch.
http://bugzilla.gnome.org/show_bug.cgi?id=313671

++++ hal-resmgr:

- put pda serial ports into class "pda" where users have access to
by default (#104426)

++++ hwinfo:

- rip out all special tulip-related module info (#105730)
- load lp module (#104874)
- pcmcia probing works again (#103740)
- support 'modalias' sysfs entries (#103740, #103978)
- getsysinfo collects a bit more info
- drop pci.handmap code (after talking to zoz)

++++ ial:

- fixed description for yast2 runlevel editor (closes #105675)

++++ k3b:

- use HAL/DBUS for media change notification
- change default sound for "burning finished" with a shorter one

++++ kdar:

- fix file list for icons

++++ kdeaccessibility3:

- fix file list for icons

++++ kdebase3:

- update to 3.4 branch
- trying to fix floppy support

++++ kdebluetooth:

- fix file list for icons

++++ kdegraphics3:

- Fixes for the camera:/ io-slave reported by coolo:
- do not hang on some special errors.
- fixed problem with camera://Camera@Port without leading /

++++ kdelibs3:

- fix endless loop, if no KDEMM backend can get found (#105772)
- Fix QXEmbed to have focus working properly in yast+kcontrol
(#46495).

++++ kdetv:

- fix file list for icons

++++ kernel-bigsmp:

- enable sata_vsc and sata_ahci on ppc64
- update to 2.6.13-rc6-git11, network, ide, nfs, md fixes
- patches.drivers/alsa-2.6.12-git.diff: ALSA GIT update.
- patches.drivers/alsa-ppc-screamer-endian-workaround: A
workaround for PMac screamer endian problem (105600).
- Better version of rediffed Xen patches from Jan and additional
fixes.
- patches.fixes/nfsd-rewrite-align: Fix logical bug (97941, 96957).
- patches.suse/bootsplash: Bootsplash update from mls.
- series.conf: disable nfsd-rewrite-align; it's broken
- Adapt the other 2.6.13-rc changes to Xen and enable.
- Import 2.6.13-rc changes into Xen up to 2.6.13-rc4 (Charles).
- enable amd8111e on ppc64
- Update open-iscsi to svn r401.
- Update open-iscsi to svn r399.

++++ kernel-default:

- enable sata_vsc and sata_ahci on ppc64
- update to 2.6.13-rc6-git11, network, ide, nfs, md fixes
- patches.drivers/alsa-2.6.12-git.diff: ALSA GIT update.
- patches.drivers/alsa-ppc-screamer-endian-workaround: A
workaround for PMac screamer endian problem (105600).
- Better version of rediffed Xen patches from Jan and additional
fixes.
- patches.fixes/nfsd-rewrite-align: Fix logical bug (97941, 96957).
- patches.suse/bootsplash: Bootsplash update from mls.
- series.conf: disable nfsd-rewrite-align; it's broken
- Adapt the other 2.6.13-rc changes to Xen and enable.
- Import 2.6.13-rc changes into Xen up to 2.6.13-rc4 (Charles).
- enable amd8111e on ppc64
- Update open-iscsi to svn r401.
- Update open-iscsi to svn r399.

++++ kernel-smp:

- enable sata_vsc and sata_ahci on ppc64
- update to 2.6.13-rc6-git11, network, ide, nfs, md fixes
- patches.drivers/alsa-2.6.12-git.diff: ALSA GIT update.
- patches.drivers/alsa-ppc-screamer-endian-workaround: A
workaround for PMac screamer endian problem (105600).
- Better version of rediffed Xen patches from Jan and additional
fixes.
- patches.fixes/nfsd-rewrite-align: Fix logical bug (97941, 96957).
- patches.suse/bootsplash: Bootsplash update from mls.
- series.conf: disable nfsd-rewrite-align; it's broken
- Adapt the other 2.6.13-rc changes to Xen and enable.
- Import 2.6.13-rc changes into Xen up to 2.6.13-rc4 (Charles).
- enable amd8111e on ppc64
- Update open-iscsi to svn r401.
- Update open-iscsi to svn r399.

++++ kernel-source:

- enable sata_vsc and sata_ahci on ppc64
- update to 2.6.13-rc6-git11, network, ide, nfs, md fixes
- patches.drivers/alsa-2.6.12-git.diff: ALSA GIT update.
- patches.drivers/alsa-ppc-screamer-endian-workaround: A
workaround for PMac screamer endian problem (105600).
- Better version of rediffed Xen patches from Jan and additional
fixes.
- patches.fixes/nfsd-rewrite-align: Fix logical bug (97941, 96957).
- patches.suse/bootsplash: Bootsplash update from mls.
- series.conf: disable nfsd-rewrite-align; it's broken
- Adapt the other 2.6.13-rc changes to Xen and enable.
- Import 2.6.13-rc changes into Xen up to 2.6.13-rc4 (Charles).
- enable amd8111e on ppc64
- Update open-iscsi to svn r401.
- Update open-iscsi to svn r399.

++++ kernel-um:

- enable sata_vsc and sata_ahci on ppc64
- update to 2.6.13-rc6-git11, network, ide, nfs, md fixes
- patches.drivers/alsa-2.6.12-git.diff: ALSA GIT update.
- patches.drivers/alsa-ppc-screamer-endian-workaround: A
workaround for PMac screamer endian problem (105600).
- Better version of rediffed Xen patches from Jan and additional
fixes.
- patches.fixes/nfsd-rewrite-align: Fix logical bug (97941, 96957).
- patches.suse/bootsplash: Bootsplash update from mls.
- series.conf: disable nfsd-rewrite-align; it's broken
- Adapt the other 2.6.13-rc changes to Xen and enable.
- Import 2.6.13-rc changes into Xen up to 2.6.13-rc4 (Charles).
- enable amd8111e on ppc64
- Update open-iscsi to svn r401.
- Update open-iscsi to svn r399.

++++ kernel-xen:

- enable sata_vsc and sata_ahci on ppc64
- update to 2.6.13-rc6-git11, network, ide, nfs, md fixes
- patches.drivers/alsa-2.6.12-git.diff: ALSA GIT update.
- patches.drivers/alsa-ppc-screamer-endian-workaround: A
workaround for PMac screamer endian problem (105600).
- Better version of rediffed Xen patches from Jan and additional
fixes.
- patches.fixes/nfsd-rewrite-align: Fix logical bug (97941, 96957).
- patches.suse/bootsplash: Bootsplash update from mls.
- series.conf: disable nfsd-rewrite-align; it's broken
- Adapt the other 2.6.13-rc changes to Xen and enable.
- Import 2.6.13-rc changes into Xen up to 2.6.13-rc4 (Charles).
- enable amd8111e on ppc64
- Update open-iscsi to svn r401.
- Update open-iscsi to svn r399.

++++ kimdaba:

- fix file list for icons

++++ koffice-i18n:

- update to version 1.4.1 (forgotten, #105474)

++++ kwebget:

- fix file list for icons

++++ mlterm:

- added icon file and fixed desktop file (#105842)

++++ netdiag:

- Fix a small compiler warning.

++++ nfs-utils:

- added NFS4_SUPPORT and NFS_SECURITY_GSS to sysconfig.nfs
- updated the idmapd script so it honors NFS4_SUPPORT
- updated gssd script so it honors NFS_SECURITY_GSS
- added svcgssd script

++++ openswan:

- Updated to openswan 2.4.0rc1; obsoletetes patches:
openswan_05_checkv199.dif, openswan_11_yyerror.dif,
openswan_13_system.dif, openswan_20_noslave.dif,
openswan_21_sigmask.dif, openswan_25_noxauth.dif,
openswan_30_newhostkey.dif, openswan_36_ipsec_look.dif
- Applied diverse fixes for signed issues from cvs head:
new patch file: openswan_11_gcc4cvshead.dif

++++ pam:

- Add Novell Tier1 translations

++++ perl-Bootloader:

- fixed kernel/initrd specification in merged sections (#105660)

++++ qt3:

- Place dialog properly for systray icons on xinerama (#104794).

++++ qt3-extensions:

- Place dialog properly for systray icons on xinerama (#104794).

++++ ruby:

- Build RI and html documentation. Added subpackages for them.
- moved samples into a sub packages.
- build tcl/tk bindings and move them into their own package.
(ruby-1.8.2-tcltk-multilib.patch)
- disabled optimization on ia64/x86_x64. needs investigation.
- fixed parameter swap in memset call
(ruby-1.8.2-strscan-memset.patch)
- let mkmf create shared libraries (ruby-mkmf-shared.patch)
- splitted of devel files

++++ scim:

- Bugzilla #105319: make /FrontEnd/X11/Dynamic = false the
default again to make sure that Compose works always.
- Bugzilla #105193: add "Zenkaku_Hankaku" to
/Hotkeys/FrontEnd/Trigger (this is the trigger key used MS IME
for Japanese).

++++ scsi:

- Add dir /usr/include/scsi to filelist

++++ skim:

- Bugzilla #105319: make /FrontEnd/X11/Dynamic = false the
default again to make sure that Compose works always.
- Bugzilla #105193: add "Zenkaku_Hankaku" to
/Hotkeys/FrontEnd/Trigger (this is the trigger key used MS IME
for Japanese).
- make "/FrontEnd/SharedInputMethod = true" the default.
- Bugzilla #105319: apply patch by Zhe Su to
force the use of "kconfig" with skim if available
(See comment #13 in Bugzilla #105319).

++++ sound-juicer:

- Add fam and krb5 to nfb to fix build

++++ submount:

- fixed hald-subfs-mount part of bug #94936. We add now a key
"storage.is_mounted" == TRUE to HAL if hald-subfs-mount mount
a floppy or zip drive

++++ subversion:

- hide SVN_VIEWCVS_MODPYTHON section in IfModule mod_python.c
update viewcvs, more permission fixes
update svnbook

++++ sysconfig:

- move static lib and la file to /usr

++++ wxGTK:

- Removed references to no more provided PangoRenderX calls.

++++ xen:

- Update to mercurial changeset 6223.
- Move /usr/libexec/xen/ to /usr/lib[64]/xen/bin/.
- Split off -tools package.

++++ xine-lib:

- move mpeg codecs to -mad package
- convert default video into theora format

++++ xorg-x11:

- pc_dpms.diff:
* removed r128 hunk for now (Bug #105511)
- p_enable-via-on-AMD64.diff:
* enable via driver build on AMD64 (Bug #98907, Comment #27/28)

++++ yast2-bootloader:

- enhanced checking whether merged section is still valid (#74252)
- fix information about disk geometry in MBR if needed (#103031)
- 2.12.20

++++ yast2-core:

- Added macro player support for the other event-releated UI builtins:
WaitForEvent(), WaitForEvent( timeout ), TimeoutUserInput()
to fix bug #98265: Macro player doesn't work
- V 2.12.23
- Reintroduced the UI layout engine's change reverted on 2005-08-04
by jsrain below now that the true cause of the problem is
established
- V 2.12.22

++++ yast2-http-server:

- add write to dns

++++ yast2-inetd:

- fixed bug #105456, AutoInstallation never enabled services
mentioned in the profile because the 'default' generated
configuration contained './etc/' path instead of '/etc/'.
- fixing testsuite
- 2.12.5

++++ yast2-installation:

- reverted forcing language dialog in NCurses (#102958)
- 2.12.21
- fixed mouse probing call, was never called in initial stage (#100665)
- improved initialisation of libstorage callbacks (bug #105562)

++++ yast2-packagemanager:

- Unescape usernames and passwords passed to libcurl. Curl unescapes
them if they are included in the URL, but passed as separate option
we have to unescape them. (#96960)
- 2.12.15

++++ yast2-packager:

- changed the way source refresh is set on/off
- 2.12.23

++++ yast2-pkg-bindings:

- Provide installation source attribute 'autorefresh' in
PKG::SourceGeneralData.
- 2.12.7

++++ yast2-sound:

- mixer - initialize also "Front", "Headphone" and "Master Mono"
channels (#105486)
- 2.12.9

++++ yast2-storage:

- improved initialisation of libstorage callbacks (bug #105562)

++++ yast2-vm:

- use properly custom installation source
- mount partitions in virtual disk image
- search for kernel files, copy them to domain0
- search for root device name
- update VM configuration file before starting the 2nd stage
- create link in /etc/xen/auto when 'on boot' start
mode is selected
- add TERM=xterm kernel option (to have colours in 2nd stage)
- 2.12.2

++++ yelp:

- Updated yelp-updates.patch
- move code from previous change from post to install section

------------------------------------------------------------------
------------------ 2005-8-18 - Aug 18 2005 -------------------
------------------------------------------------------------------

++++ CheckHardware:

- translation updates for de/es/it/ja
- new translations for fr/pt_BR/zh_CN/zh_TW

++++ MozillaFirefox:

- fixed regression in profile locking change (bmo #303633)
- added rtsp handler to global config (#104434)
- don't blacklist help: protocol (bmo #304833)
- fixed Gdk-WARNING at startup (gtk.patch)
- fixed crash with gtk 2.7 (bmo #300226, bnc #104586)
- fixed installation of the beagle plugin
- update industrial theme to 1.0.11 (#104564)
- included lockdownV2 (removed obsolete gconf.diff)
- linked firefox-bin with rpath to progdir

++++ OpenOffice_org:

- updated to version 1.9.124
- updated ooo-build to version 1.9.124:
* target m124
* 'save as rendered' option while exporting to .csv
* allow to disable the VBA feature at runtime
* some fixes of the cairo canvas stuff
* default option in the templates and documents dialog fix
* warning about usage of an undefined variable in install-dict
* unnecessary error messages from hunspell
* possibility to turn off strip
* allow to use ARCH_FLAGS when building partaudio
- updated extra translation sources: Czech, Danish, Estonian, Slovak
- updated cairo source, version 0.9.0 (used just for older distributions)
- updated branding once more for 10.0 [#102355]
- fixed provides of the officebean subpackage
- disabled strip by the native installer
- fixed permissions of installed libraries and modules
- fixed a return in the VBA stuff
- fixed a crash with evo2 [#104462]
- fixed to get proper ms access tab page for creating msaccess db

++++ aaa_base:

- changed you alias (#105479)
- do not sleep but sync after the log file is written
- Do not set and export proxy control variables if empty (#104727)
- Set LC_ALL to POSIX in rc.status for well defined locale for
all boot and runlevel scripts (bug #105322)
- Make DISABLE_ECN work even for "no" (bug #105175)

++++ alsa:

- Fix invalid read warnings detected by valgrind2 (#105572)
- Fixed races in direct plugins (#104884)
- Fix/clean up aoss wrapper
- Fixed memory leak in alsa-lib pcm configuration

++++ alsa-tools:

- removed obsolete hotplug files (#105276)
- fix bitops of ld10k1 to be 64bit clean.

++++ apt4rpm:

- added --nodigest to RPM_NOSIGNATURE_ARG to speed up aptate
- fixed requires

++++ cairo:

- RPM can calculate dependencies much better than using a
hardcoded list

++++ samba:

- Fix assembling of the filepath in vscan-icap; [#105582].
- Fix typo in vscan-mcdaemon; [#102372].

++++ gcc:

- Update to current CVS.

++++ deltarpm:

- use $RPM_OPT_FLAGS

++++ dia:

- Patch to fix bugzilla.novell.com defect#6341 - "popup of group
properties is too small"

++++ dosbootdisk:

- change floppy device name to fd0u1440 (#105446)

++++ evince:

- Update to version 0.3.4
- Put evince in correct desktop category

++++ glitz:

- Moved so file to devel subpackage (#105470).

++++ gnome-menus:

- Add patch to get rid of Applications->Applications.

++++ gnome-volume-manager:

- Updated to version 1.3.5
- Removed previous banshee patch
- Added patch to set our own schema defaults

++++ gtk-sharp2:

- Add dependencies on Perl xml packages for gapi (Novell [Bug 105055])

++++ gtk2:

- Update version to 2.8.0 (GNOME2.12)

++++ kdebase3:

- kdm sets config variable for xauth (#98627)

++++ kdelibs3:

- do not use KLIRRRRR sound on popular request ...
- extend kde_post_install of common_options

++++ kdenetwork3:

- update to current 3_4_BRANCH
* fix Kopete bug where default plugins are not actually loaded
* fix Kopete bug breaking GroupWise auto-away

++++ kernel-bigsmp:

- Enabled NFSv4, fixed up configs
- Update Xen patches to Xen3 hg 6223.
- Merge old Xen patches that are still applicable.
- update to 2.6.13-rc6-git10, network, zlib, ntfs, other fixes
- patches.fixes/ide-cs-correct-device-link
Correct device link for ide-cs devices (#104670)

++++ kernel-default:

- Enabled NFSv4, fixed up configs
- Update Xen patches to Xen3 hg 6223.
- Merge old Xen patches that are still applicable.
- update to 2.6.13-rc6-git10, network, zlib, ntfs, other fixes
- patches.fixes/ide-cs-correct-device-link
Correct device link for ide-cs devices (#104670)

++++ kernel-smp:

- Enabled NFSv4, fixed up configs
- Update Xen patches to Xen3 hg 6223.
- Merge old Xen patches that are still applicable.
- update to 2.6.13-rc6-git10, network, zlib, ntfs, other fixes
- patches.fixes/ide-cs-correct-device-link
Correct device link for ide-cs devices (#104670)

++++ kernel-source:

- Enabled NFSv4, fixed up configs
- Update Xen patches to Xen3 hg 6223.
- Merge old Xen patches that are still applicable.
- update to 2.6.13-rc6-git10, network, zlib, ntfs, other fixes
- patches.fixes/ide-cs-correct-device-link
Correct device link for ide-cs devices (#104670)

++++ kernel-um:

- Enabled NFSv4, fixed up configs
- Update Xen patches to Xen3 hg 6223.
- Merge old Xen patches that are still applicable.
- update to 2.6.13-rc6-git10, network, zlib, ntfs, other fixes
- patches.fixes/ide-cs-correct-device-link
Correct device link for ide-cs devices (#104670)

++++ kernel-xen:

- Enabled NFSv4, fixed up configs
- Update Xen patches to Xen3 hg 6223.
- Merge old Xen patches that are still applicable.
- update to 2.6.13-rc6-git10, network, zlib, ntfs, other fixes
- patches.fixes/ide-cs-correct-device-link
Correct device link for ide-cs devices (#104670)

++++ libgphoto2:

- removed /etc/hotplug/usb/usbcam.usermap use. #105276

++++ libopensync:

- upgraded to svn and added some patches to fix segfaults on 64bit

++++ libopensync-plugin-kdepim:

- change requires from qt -> qt3

++++ libsoup:

- update to cvs version folding in other patches
- added libsoup-2.2.3-danw-tambet-threading.patch

++++ manufacturer-PPDs:

- Added 136 pxlmono driver (PCLXL resp. "PXL") Ricoh PPD files
(i.e. for Ricoh, Gestetner, Infotec, Lanier, NRG, and Savin).

++++ monodevelop:

- Fix desktop category for menus.

++++ multisync-gui:

- updated to svn-version to fix some problems on 64bit

++++ openssh:

- added patch tmpdir.diff for using $TMPDIR by ssh-agent [#95731]

++++ orbit2:

- Update to version 2.12.3

++++ pam_ldap:

- when handling new password policy control, only fall through
to account management module if a policy error was returned
(Bug #105118)

++++ pango:

- Update to version 1.10.0

++++ patch:

- --reject-unified is called --unified-reject-files [#105151]

++++ perl:

- remove postun, handle it with ghosts

++++ perl-Bootloader:

- fixed order of lines in XEN sections (#105171)

++++ poppler:

- Update to version 0.4.0
- Remove uptreamed patchs

++++ rcd:

- updated rcd-2.4.8-tambet-memory-management-95454.patch

++++ scim:

- Bugzilla #105319: fix typo in our patch of the default config
(Shift+space instead of Shift+Space).

++++ skim:

- Bugzilla #105319: fix typo in our patch of the default config
(Shift+space instead of Shift+Space).

++++ suse-release-oss:

- Beta3

++++ sysconfig:

- ifup: removed switch USE_IPV6, because it is silly. (Bug 105436)
- hardware/scripts/functions: cleaned up

++++ tcsh:

- Update to tcsh 6.14.00, the wide character version (bug #104108).

++++ toshutils:

- removed .o-files. we want to have explicit compiler runs
- fixed specfile
- fixed implicit function calls
- fixed 64bit building

++++ udev:

- Upstream Version 068

++++ xorg-x11:

- simplified filelist

++++ yast2:

- added simple XEN detection (workaround for #100726)
- select kernel-xen if XEN is detected
- 2.12.23
- Do not Read() NetworkDevices when running CWMFirewallInterfaces
in Installation or Update.
- Set SuSEFirewallProposal as 'modified' when changing the firewall
counfiguration via CWMFirewallInterfaces in Installation or
Update (bug #105170).

++++ yast2-bootloader:

- fixed new created XEN sections (#105171)
- do not install backup of stage1 if /boot is on XFS (#105483)
- 2.12.19

++++ yast2-mouse:

- merged one text after the proofreading
- 2.12.7

++++ yast2-network:

- More valid characters for proxy user name (#103841).

++++ yast2-packagemanager:

- Make shure curl_global_init/curl_global_cleanup are called only
once. (#103005)
- Prevent SEGV in packages file is corrupted. (#105006)
- check candidate set when calculating packages to remove (#104601)

++++ yast2-packager:

- fixed list of packages for VNC installation (#105167)
- added alternative dialog for desktop selection (#104643)
- don't reset software selection if disk exhausted, just warn user
and prevent from installing (#104626)
- 2.12.22
- checkmedia - adapted to the new version of checkmedia utility
- fixed switching automatical source refresh on/off (#104995)

++++ yast2-pam:

- autologin: call correct SuSEconfig module for GDM (#74198)
- 2.12.3

++++ yast2-qt:

- V 2.12.10
- Now using llunak's updated qxembed.{cc,h} to fix bug #46495:
Keyboard focus problems with YaST2 embedded into KControl

++++ yast2-repair:

- adapted for API changes in yast2-bootloader
- 2.12.6

++++ yast2-runlevel:

- Proposal should not return any `nil` as the value of the warning
and warning_level key (bug #105154).
- 2.12.4

++++ yast2-scanner:

- V 2.12.14
- Avoid to show duplicate manufacturer name when it is also a part
of the model name like in "EPSON Epson Perfection 123".
- Fix killing of the time bomb in setup_ptal_scanner_service.

++++ yast2-storage:

- check for mounted LV before removing LVM LV (#105205)
- do not remove backups when re-reading partition table (#105438)
- avoid to hit parted bug when creating logical partitions (#105441)
- fix crash during raid handling in installed system (#105387)
- 2.12.20

++++ yast2-update:

- changes needed for udpate with crypted partition (#105020)
- 2.12.7

------------------------------------------------------------------
------------------ 2005-8-17 - Aug 17 2005 -------------------
------------------------------------------------------------------

++++ CheckHardware:

- added new translations for da

++++ NX:

- updated to the latest stable 1.5.0 release of nxagent/nxdesktop
* nxagent: 1.5.0-87 --> 1.5.0-90
* nxdesktop: 1.5.0-59 --> 1.5.0-61

++++ aaa_base:

- Remove the -p option from faillog in csh.login
- Add check for new tcsh 6.14 which does not use dspmbyte

++++ amarok:

- finally fixed default paths for RealPlayer

++++ arts:

- let arts start it self
- pleasing the libtool check

++++ autoyast2:

- compatibility to storage lib
(type was missing in TargetMap)
- 2.12.10

++++ beagle:

- Use beagle-index rather than nobody (104645).

++++ cairo:

- Update to version 0.9.2

++++ checkmedia:

- take padding into account

++++ gcc:

- Enable Ada on hppa.
- cross-avr-gcc: Enabled avr2 support in micro-cross.spec.in
fixes #105206
- micro-cross.spec.in more robust against gcc.spec changes.

++++ cracklib:

- Add translations for da, lt, nb, pa and pt
- Fixes #105413

++++ digikam:

- do not overwrite ports with "usb:" everytime.

++++ fam:

- Provide file_alteration virtual.
- Provide /var/run/fam for gnome-vfs2 dloader.

++++ glitz:

- Update to version 0.4.4

++++ gnome-session:

- Improve performance of logout fading.

++++ hal-resmgr:

- add README

++++ iproute2:

- update to version 050816 [#105087]

++++ kdeartwork3:

- we don't need no arts in screensavers

++++ kdelibs3:

- move arts dependency to -arts package
- clean up really all SimplePlayers in knotify, might cause a crash
which needs to be debugged

++++ kernel-bigsmp:

- update to 2.6.13-rc6-git9, inotify, nfts, acpi hotkey, jfs fixes
- patches.suse/netfilter-02-output-hooks: nat over ipsec.
- patches.suse/netfilter-03-input-hooks: nat over ipsec.
- patches.suse/netfilter-04-policy-lookup: nat over ipsec.
- patches.suse/netfilter-05-policy-checks: nat over ipsec.
- Update config files.
- patches.drivers/e100-update: Obsolete
- patches.drivers/megaraid-new: Obsolete
- patches.drivers/suse-ahci-disable: Obsolete
- patches.drivers/swsusp-b44: Obsolete
- patches.drivers/swsusp-via-velocity: Obsolete
- patches.drivers/usb-qc-usb-*: Obsolete
- patches.fixes/mtrr-check-gpf: Obsolete
- patches.fixes/posix-locks-race: Obsolete
- patches.fixes/procmisc-cached-underflow: Obsolete
- patches.fixes/quiet-sched: Obsolete
- patches.fixes/x86_64-panic-lockup: Obsolete
- remove patches.fixes/atapi-fix-error-handling.patch
- remove patches.fixes/libata-no-complete-on-error
Newer version of libata error handling is on mainline.

++++ kernel-default:

- update to 2.6.13-rc6-git9, inotify, nfts, acpi hotkey, jfs fixes
- patches.suse/netfilter-02-output-hooks: nat over ipsec.
- patches.suse/netfilter-03-input-hooks: nat over ipsec.
- patches.suse/netfilter-04-policy-lookup: nat over ipsec.
- patches.suse/netfilter-05-policy-checks: nat over ipsec.
- Update config files.
- patches.drivers/e100-update: Obsolete
- patches.drivers/megaraid-new: Obsolete
- patches.drivers/suse-ahci-disable: Obsolete
- patches.drivers/swsusp-b44: Obsolete
- patches.drivers/swsusp-via-velocity: Obsolete
- patches.drivers/usb-qc-usb-*: Obsolete
- patches.fixes/mtrr-check-gpf: Obsolete
- patches.fixes/posix-locks-race: Obsolete
- patches.fixes/procmisc-cached-underflow: Obsolete
- patches.fixes/quiet-sched: Obsolete
- patches.fixes/x86_64-panic-lockup: Obsolete
- remove patches.fixes/atapi-fix-error-handling.patch
- remove patches.fixes/libata-no-complete-on-error
Newer version of libata error handling is on mainline.

++++ kernel-smp:

- update to 2.6.13-rc6-git9, inotify, nfts, acpi hotkey, jfs fixes
- patches.suse/netfilter-02-output-hooks: nat over ipsec.
- patches.suse/netfilter-03-input-hooks: nat over ipsec.
- patches.suse/netfilter-04-policy-lookup: nat over ipsec.
- patches.suse/netfilter-05-policy-checks: nat over ipsec.
- Update config files.
- patches.drivers/e100-update: Obsolete
- patches.drivers/megaraid-new: Obsolete
- patches.drivers/suse-ahci-disable: Obsolete
- patches.drivers/swsusp-b44: Obsolete
- patches.drivers/swsusp-via-velocity: Obsolete
- patches.drivers/usb-qc-usb-*: Obsolete
- patches.fixes/mtrr-check-gpf: Obsolete
- patches.fixes/posix-locks-race: Obsolete
- patches.fixes/procmisc-cached-underflow: Obsolete
- patches.fixes/quiet-sched: Obsolete
- patches.fixes/x86_64-panic-lockup: Obsolete
- remove patches.fixes/atapi-fix-error-handling.patch
- remove patches.fixes/libata-no-complete-on-error
Newer version of libata error handling is on mainline.

++++ kernel-source:

- update to 2.6.13-rc6-git9, inotify, nfts, acpi hotkey, jfs fixes
- patches.suse/netfilter-02-output-hooks: nat over ipsec.
- patches.suse/netfilter-03-input-hooks: nat over ipsec.
- patches.suse/netfilter-04-policy-lookup: nat over ipsec.
- patches.suse/netfilter-05-policy-checks: nat over ipsec.
- Update config files.
- patches.drivers/e100-update: Obsolete
- patches.drivers/megaraid-new: Obsolete
- patches.drivers/suse-ahci-disable: Obsolete
- patches.drivers/swsusp-b44: Obsolete
- patches.drivers/swsusp-via-velocity: Obsolete
- patches.drivers/usb-qc-usb-*: Obsolete
- patches.fixes/mtrr-check-gpf: Obsolete
- patches.fixes/posix-locks-race: Obsolete
- patches.fixes/procmisc-cached-underflow: Obsolete
- patches.fixes/quiet-sched: Obsolete
- patches.fixes/x86_64-panic-lockup: Obsolete
- remove patches.fixes/atapi-fix-error-handling.patch
- remove patches.fixes/libata-no-complete-on-error
Newer version of libata error handling is on mainline.

++++ kernel-um:

- update to 2.6.13-rc6-git9, inotify, nfts, acpi hotkey, jfs fixes
- patches.suse/netfilter-02-output-hooks: nat over ipsec.
- patches.suse/netfilter-03-input-hooks: nat over ipsec.
- patches.suse/netfilter-04-policy-lookup: nat over ipsec.
- patches.suse/netfilter-05-policy-checks: nat over ipsec.
- Update config files.
- patches.drivers/e100-update: Obsolete
- patches.drivers/megaraid-new: Obsolete
- patches.drivers/suse-ahci-disable: Obsolete
- patches.drivers/swsusp-b44: Obsolete
- patches.drivers/swsusp-via-velocity: Obsolete
- patches.drivers/usb-qc-usb-*: Obsolete
- patches.fixes/mtrr-check-gpf: Obsolete
- patches.fixes/posix-locks-race: Obsolete
- patches.fixes/procmisc-cached-underflow: Obsolete
- patches.fixes/quiet-sched: Obsolete
- patches.fixes/x86_64-panic-lockup: Obsolete
- remove patches.fixes/atapi-fix-error-handling.patch
- remove patches.fixes/libata-no-complete-on-error
Newer version of libata error handling is on mainline.

++++ kernel-xen:

- update to 2.6.13-rc6-git9, inotify, nfts, acpi hotkey, jfs fixes
- patches.suse/netfilter-02-output-hooks: nat over ipsec.
- patches.suse/netfilter-03-input-hooks: nat over ipsec.
- patches.suse/netfilter-04-policy-lookup: nat over ipsec.
- patches.suse/netfilter-05-policy-checks: nat over ipsec.
- Update config files.
- patches.drivers/e100-update: Obsolete
- patches.drivers/megaraid-new: Obsolete
- patches.drivers/suse-ahci-disable: Obsolete
- patches.drivers/swsusp-b44: Obsolete
- patches.drivers/swsusp-via-velocity: Obsolete
- patches.drivers/usb-qc-usb-*: Obsolete
- patches.fixes/mtrr-check-gpf: Obsolete
- patches.fixes/posix-locks-race: Obsolete
- patches.fixes/procmisc-cached-underflow: Obsolete
- patches.fixes/quiet-sched: Obsolete
- patches.fixes/x86_64-panic-lockup: Obsolete
- remove patches.fixes/atapi-fix-error-handling.patch
- remove patches.fixes/libata-no-complete-on-error
Newer version of libata error handling is on mainline.

++++ wireless-tools:

- rtl8180: intially added
- minor specfile cleanup

++++ kyum:

- initial package (version 0.7.5)

++++ libgphoto2:

- Merged to current CVS.
- New "disk:" support to support mass storage cameras (written
by Marcus M.), changes in libgphoto2_port/disk/disk.c, libgphoto2/
gphoto2-abilities-list.c and camlibs/directory/directory.c.
Tested and working with gphoto2, f-spot, digikam, and KDE camera:/
- usb - suppress some unnecessary "usb:XXX,YYY" ports.
- escape & in HAL FDI maps.
- Some small bugfixes and new ids.

++++ mkinitrd:

- Pass only valid parameters to init (#104984).
- Remove ROOT= parameter parsing
- Do not evaluate IDE modules if network interface is set (#83782).

++++ mozilla:

- don't blacklist help: protocol (bmo #304833)
- fixed regression in profile locking change (bmo #303633)
- fixed Gdk-WARNING at startup (gtk.patch)
- fixed crash with gtk 2.7 (bmo #300226, bnc #104586)

++++ pam_krb5:

- got official fix for the authtok problem
[#104051]

++++ perl-Bootloader:

- fixed installing GRUB if /boot is on MD array (104908)
- fixed displayed paths in configuration file editor during
bootloader installation (105140)

++++ pinfo:

- Fixed a heap corruption bug caused by lines starting with NUL byte
(#94768)

++++ pwdutils:

- Update to pam_login 3.24 (update of manual pages)
- Update to pwdutils 3.0.4
- usermod: Adjust sp_lstchg if -p option is used
- useradd: Preserve existing home directory
- chage: Fix off-by-one errors in output
- Fix loading of logging plugins
- Add -a option to usermod for shadow compatibility

++++ quilt:

- CVS update.

++++ rcd:

- added patch for memory management (#95454)

++++ resmgr:

- add pda class (#104426)

++++ sax2:

- fixed keyboard toggle setup (#105420)
- fixed appearance of scrolling pixmaps in mouse test field (#105781)
- fixed CDB entries for various SAMSUNG monitors (#105577) (#105565)
- include information box if VNC has been activated to setup the
needed RFB and HTTP ports within the firewall setup as well (#105628)
- fixed FireGL profile to use internal mode pool only
- fixed mouse detection on ppc64, button detection with libhd
is failing (#102743)
- update translations from dublin

++++ sysconfig:

- functions.common: added new functions {,err,info,debug}_mesg()
If not set explicitely via LOG_LEVEL these check the udev loglevel.
- rename_netiface:
+ removed logging into a file in /tmp (Bug 104606)
+ use mktemp for temporary files

++++ util-linux:

- Add option 'hotplug' to mount (#104405)

++++ x11-tools:

- nvidia-installer-proxy.diff:
* fixes tiny-nvidia-installer when FTP_PROXY is set to ""
(Bug #104727)

++++ xcompmgr:

- removed /opt/kde3/share/autostart/xcompmgr.desktop (Bug #104940)

++++ xkeyboard-config:

- ibm_space_saver.diff:
* add support for "ibm_space_saver" keyboards (Bug #59788)

++++ xorg-x11:

- updated exa module/sis driver to current CVS version (2005-08-17)
* Fix the exa pixmap offset/pitch alignment to deal with non-POT
alignment requirements. MGA, notably, uses a multiple of 3 in
some cases.
* Rename the pixmap offset/pitch alignment fields to more clearly
state their meaning.
- adjusted ps_x86-64_ioctl32.diff

++++ yast2-bootloader:

- fixed detection whether bootloader can be installed if /boot is
on MD (#104908)
- fixed comments for ycpdoc
- fixed proposing configuration if /boot is on MD (#104908)
- set correct initrd image for XEN (#105171)
- fixed errors in log while proposing loader type (#105152)
- don't remove initrd from merged loader sections (#104048)

++++ yast2-country:

- better solution for CJK languages during installation (#102958)
- fixed the icon names (#105157, #105163)
- 2.12.12

++++ yast2-installation:

- added umount_result key to /etc/install.inf containing the exit
code from trying to umount the inst-sys (#103800)
- 2.12.19
- handle correctly if _proposal client returns nil as warning level
(#105154)
- check if /sbin/splash exists (bug #105159)
- 2.12.18

++++ yast2-network:

- Enable firewall for newly added modems and DSLs (#66478).
- 2.12.11

++++ yast2-packagemanager:

- fix handling of multiple provides of the same name by the same
package (#105127)

++++ yast2-pkg-bindings:

- Removed obsolete 'TargetUpdateInf'. That's old YaST(1)
stuff.
- 2.12.6

++++ yast2-scanner:

- V 2.12.13
- Changed "/sbin/lsusb" to "/usr/sbin/lsusb" in the help text.

++++ yast2-storage:

- fix check for boot size with raid (bug #104931)
- use recursive removal for with Storage::SetTargetMap (bug #104929)
- fix bugs regarding recursive removal of md devices (bug #104929)
- improve layout in inst_part_proposal.ycp (#102981)
- fix detection of BSD disk labels (#104939)
- fix wrong value in FileSystems::LabelLength (#105180)
- fixes to make update with crypted partitions work (#105020)
- 2.12.19

++++ yast2-trans-cs:

- Update to version 2.12.3.

++++ yast2-trans-de:

- Update to version 2.12.4.

++++ yast2-trans-it:

- Update to version 2.12.2.

++++ yast2-x11:

- fixed message text (#105234)

More in Tux Machines

OpenShift and Google

  • Red Hat launches 'OpenShift' dedicated on Google Cloud Platform
    World's leading provider of open source solutions Red Hat has announced the general availability of OpenShift Dedicated on Google Cloud Platform.
  • Red Hat and Google join forces on containers
    Red Hat and Google are set to offer enterprise customers a managed OpenShift service hosted on Google's cloud to make the build, launch and management of applications a less time-consuming process. OpenShift Dedicated on Google Cloud Platform will speed up the adoption of containers, according to Red Hat, giving developers the guidance they need to create applications and deploy them faster.
  • Red Hat’s Container Platform Lands on Google Cloud
    Red Hat’s OpenShift Dedicated container platform will now be available on Google Cloud Platform, the companies announced yesterday. OpenShift Dedicated is a managed version of Red Hat’s OpenShift container platform, targeting enterprises. Launched in December, the Dedicated version puts Red Hat in the role of a service provider, taking care of infrastructure and operations.

Security News

  • A 'mystery device' is letting thieves break into cars and drive off with them, insurance group says
    Insurance crime investigators are raising alarms over a device that not only lets thieves break into cars that use keyless entry systems but also helps start and steal them. Investigators from the National Insurance Crime Bureau, a not-for-profit organization, said in an interview they obtained what they called the “mystery device” from a third-party security expert at an overseas company. So far, the threat here may be mostly theoretical. The crime bureau said it heard of the device being used in Europe and had reports that it had entered the U.S., but said there are no law enforcement reports of a car being stolen using it in the United States.
  • Turkish hacking group offers tiered points rewards program for DoS attacks
    A TURKISH HACKING GANG is taking an unusual approach to funding denial of service attacks, and is soliciting for, and offering hackers rewards for taking down chosen pages. This is unusual, as far as we know, and it has led to the creation of comment from the security industry. Often these things do.
  • German judges explain why Adblock Plus is legal
    Last month, Adblock Plus maker Eyeo GmbH won its sixth legal victory in German courts, with a panel of district court judges deciding that ad-blocking software is legal despite German newsmagazine Der Spiegel's arguments to the contrary. Now, the reasoning of the Hamburg-based panel of judges has been made public. According to an unofficial English-translated copy (PDF) of the judgment, Spiegel Online argued it was making a "unified offer" to online consumers. Essentially, that offer is: read the news content for free and view some ads. While Internet users have the freedom "not to access this unified offer," neither they nor Adblock Plus have the right to "dismantle" it. Eyeo's behavior thus amounted to unfair competition, and it could even wipe the offer out, Spiegel claimed. "The Claimant [Spiegel] argues that the Defendant’s [Eyeo's] business model endangers the Claimant’s existence," reads the judgment, which isn't final because it can be appealed by Spiegel. Because users aren't willing to pay for editorial content on the Web, "it is not economically viable for the Claimant to switch to this business model." Spiegel asked for an accounting of all the blocked views on its website and a fine to be paid—or even for managers Wladimir Palant and Till Faida to be placed in "coercive detention" of up to two years.
  • Op-ed: I’m throwing in the towel on PGP, and I work in security [Ed: Onlya tool would drop PGP for Facebook-controlled Whatsapp. The company back-doors everything under gag orders.]
    In the coming weeks I'll import all signatures I received, make all the signatures I promised, and then publish revocations to the keyservers. I'll rotate my Keybase key. Eventually, I'll destroy the private keys.
  • 90 per cent of NHS Trusts are still running Windows XP machines
    90 PER CENT of the NHS continues to run Windows XP machines, two and a half years after Microsoft ditched support for the ageing OS. It's Citrix who is ringing the alarm bells, having learnt that 90 per cent of NHS Trusts are still running Windows XP PCs. The firm sent Freedom of Information (FoI) requests to 63 NHS Trusts, 42 of which responded. The data also revealed that 24 Trusts are still not sure when they'll migrate from Windows XP to a newer version of Microsoft's OS. 14 per cent said they would be transitioning to a new operating system by the end of this year, while 29 per cent pledged to make the move sometime next year.
  • Ransomware blamed for attack that caused Lincolnshire NHS Trust shutdown
    RANSOMWARE is to blame for an attack which saw an NHS Trust in Lincolnshire that forced to cancel operations for four days in October. In a statement, Northern Lincolnshire and Goole NHS Foundation Trust said that a ransomware variant called Globe2 was to blame for the incident.
  • Researchers Find Fresh Fodder for IoT Attack Cannons
    New research published this week could provide plenty of fresh fodder for Mirai, a malware strain that enslaves poorly-secured Internet of Things (IoT) devices for use in powerful online attacks. Researchers in Austria have unearthed a pair of backdoor accounts in more than 80 different IP camera models made by Sony Corp. Separately, Israeli security experts have discovered trivially exploitable weaknesses in nearly a half-million white-labeled IP camera models that are not currently sought out by Mirai.
  • Your data is not safe. Here's how to lock it down
    But some people worry that government surveillance will expand under a Donald Trump presidency, especially because he tapped Mike Pompeo, who supports mass surveillance, for CIA chief.
  • Tor at the Heart: Library Freedom Project
    Library Freedom Project is an initiative that aims to make real the promise of intellectual freedom in libraries by teaching librarians and their local communities about surveillance threats, privacy rights and responsibilities, and privacy-enhancing technologies to help safeguard digital freedoms.
  • PowerShell security threats greater than ever, researchers warn
    Administrators should upgrade to the latest version of Microsoft PowerShell and enable extended logging and monitoring capabilities in the light of a surge in related security threats, warn researchers [...] Now more than 95% of PowerShell scripts analysed by Symantec researchers have been found to be malicious, with 111 threat families using PowerShell.
  • Five-Year-Old Bait-and-Switch Linux Security Flaw Patched
    Maintainers of the Linux Kernel project have fixed three security flaws this week, among which there was a serious bug that lingered in the kernel for the past five years and allowed attackers to bypass some OS security systems and open a root shell.
  • The Internet of Dangerous Auction Sites
    Ok, I know this is kind of old news now, but Bruce Schneier gave testimony to the House of Representatives’ Energy & Commerce Committee about computer security after the Dyn attack. I’m including this quote because I feel it sets the scene nicely for what follows here. Last week, I was browsing the popular online auction site eBay and I noticed that there was no TLS. For a moment, I considered that maybe my traffic was being intercepted deliberately, there’s no way that eBay as a global company would be deliberately risking users in this way. I was wrong. There is not and has never been TLS for large swathes of the eBay site. In fact, the only point at which I’ve found TLS is in their help pages and when it comes to entering card details (although it’ll give you back the last 4 digits of your card over a plaintext channel).

Android Leftovers

Linux 4.8.14

Turns out I'm going to be on a very long flight early tomorrow morning, so I figured it would be good to get this kernel out now, instead of delaying it by an extra day. So, I'm announcing the release of the 4.8.14 kernel. All users of the 4.8 kernel series must upgrade. The updated 4.8.y git tree can be found at: git://git.kernel.org/pub/scm/linux/kernel/git/stable/linux-stable.git linux-4.8.y and can be browsed at the normal kernel.org git web browser: http://git.kernel.org/?p=linux/kernel/git/stable/linux-st... Read more Also: Linux 4.4.38 Linux Kernel 4.8.14 Hits the Streets with Numerous Networking Improvements, More