Language Selection

English French German Italian Portuguese Spanish

SimplyMEPIS 6.0 - What Happened?

Filed under
Linux
Reviews
-s

The highly anticipated SimplyMEPIS 6.0 was released on July 22. I'd been following the developmental cycle loosely by testing Alpha 1 and RC1 and being rather impressed with them, I had been quite anxious to test the final release.

This is the first Mepis release to incorporate Ubuntu packages. Where it might not be readily visible on the surface, it is more than obvious when perusing the package manager. There are a few other telltail signs here and there, but basically SimplyMEPIS 6.0 looks like a natural evolution of earlier releases.

In the press release, Warren Woodford stated, "Converting MEPIS to the Ubuntu pool while incorporating the latest Open Source software advances has taken several months, but it's been worth the effort. This appears to be the best version of SimplyMEPIS to date."

Tuxmachines will agree with that - for the most part. SimplyMEPIS has always been a good distribution. It was always stable, fast, and chocked full of applications. Many times SimplyMEPIS was one of the distros I recommended when asked. However, seems that I experienced quite a few more glitches with this release than ever in the past - even including developmental releases.

The boot process has remained consistant over this development cycle and one can log into the KDE 3.5.3 desktop as 'demo' with the password 'demo'. This release the desktop is bit less cluttered than in previous versions. The once overcrowded menus are now slimmed and trimmed, while still leaving some of the older structure and many additional applications accessible through the All Applications heading. Under the other logical headings one can find some of the most popular applications for those more common tasks. The Mepis Old OS Center is now gone from the menu and now we are giving simply a choice of System Configuration (Settings). Clicking on System Configuration brings up a new settings dialog containing all the same headings found in the KDE Control Center. Clicking on those heading brings up the corresponding KDE module in its own window. I'm not sure I see the advantage of this, but the old kcontrol is in the "All Applications" menu.

        

In the panel we still find the distinctive kaquarium applet. To me this has become a 'trademark' of sorts distinguishing SimplyMEPIS from the rest. I know of no other distro so enamored with kaquarium that it retains its place of honor in the panel from release to release. Most don't even include it at all.

Elsewhere in the panel one finds kweather and several other utilities and applets in the systray. Changing the kweather configuration through the graphical front-end for my area did not result in displaying the weather for my area. It continued to display the weather for Morgantown, WV.

On the other end of the panel beside the quick launcher is a software update reminder applet ...thingy. Upon clicking on it, Synaptic package manager opens. If updates are available, a numerical indicator signals how many. Seemed here that in order for the applet to show the updates, I needed to reload the sources and close Synaptic. At that point the indicator changed appearance and the number of updates replaced the zero. Then after installing the updates, the indicator didn't change back to zero until opening and closing Synaptic again. I think this update applet indicator thingy is a wonderful addition, but if my install is typical, it still needs a bit of refining.

        

Another quirk found on the desktop was the appearance of a second floppy icon named "Floppy Drive" when mounting another partition, instead of a hard drive indicator. When clicking on it, it stated that /dev/fd0 could not be read. Inserting a removable USB thumb drive resulted in the correct icon with correct path to the device.

Yet another little issue occurred during the install of the system from the live cd. I chose 'custom install on existing partitions' as usual, but the formatting tool kept erroring out and sending me back to step 1. I had chosen to install 6.0 on my /dev/hda15 where 6.0rc1 was installed at the time and designated /dev/hda11 as swap. The next step confirms that you would like those partitions formatted and after agreeing, this is where mine shot the error that it could not complete the format. I changed filesystem type from ext3 to reiser and back with no better results, then finally I left swap at 'no swap or already partitioned' (whatever the exact wording was), and then the install proceeded. I'm not sure what the problem was, perhaps the swap was being used by the live cd. However, when I tried clicking 'no' on the confirmation screen when asked about formatting swap it should have bypassed the error. Again I was sent back to step 1. However, leaving as 'no swap' didn't stop the swap partition configuration from showing up in the /etc/fstab of the install system. All in all, it wasn't a big deal, but it did give the impression that something was amiss. Under the same circumstances, a new prospective user might have given up.

        

The last three little small problems encountered concerned individual applications. Those were Kwave Sound Editor wouldn't open at all, the media players wouldn't play media, and the webcam application didn't see my old usb webcam. Not many systems recognize or will work with that old webcam, but previously I could count on SimplyMEPIS to the be one that would. As far as the media players, kmplayer wouldn't open anything and kaffine played the first file attempted, which was an avi. But subsequent tries (first mpgs then avis again) resulted in segfaults.

        

        

        

Otherwise the system performed very well. Big Grin

For less negative sounding coverage, see the Related Links:

some info

I cannot tell about the partitioning glitches. I did not experience any, but then again I do not have that many partitions. The flopy icon strikes me as strange, since I have not read any similar issue on the forum, but well, strange things have happened.

However, I feel that some things need to be straightened out.
First of all, the notification icon is exactly that, it notifies. In normal, everyday use you do not continuously watch for updates. So, it is setup to periodically do an apt-update and will let you know if an update was found. It is no interactive tool and should therefore not be considered as such.

The second thing I would like to mention is that Mepis can no longer include libmad0 (due to GPL licensing issues), the library package that is required to play MP3 formats. Instead (and I feel they shouldn't have, but that's another thing) a dummy libmad0 package was included that makes players crash. if you perform an upgrade of the libmad0 package, you will notice that all players work correctly.

Although there may be issues, I believe version 6 is a very good distro, and a step forward compared to 3.4.3. Evolution instead of revolution, with the ubuntu repos as a basis for continuity...

KWeather Works

It's just a bit "flaky" (and it was in previous versions of MEPIS that included it, too).

You have to add your desired station(s) first. Of course, it still won't let you actually choose it. lol

But, if you add a station, save it, exit the setup screens, and go back into them, it will let you select one of the weather station(s) you added earlier.

I usually add two for my area (at the same time removing Morgantown, which SimplyMEPIS sets by default).

Then, the first time you go back into it, you can pick one of them.

It's "buggy" (and has been in every version of SimplyMEPIS I've tried with it). But, it does work on the second or third try to configure it (after you've added new weather stations, exited and go back in). After configured, it works fine.

Jim C.

What's with the title?

"SimplyMEPIS 6.0 - What Happened?" - Sounds quite negative. SimplyMEPIS 6.0 has far few quirks than most of the other Top 10 distros.

Mepis 6 memory LEAKS....

I am a long time ubuntu user and after I killed it by trying to get Mezzo running...figured what do i have to lose so I tried Mepis. On the bright side unlike Mepis 3.xx it detected all my hardware (even wireless), and thanks to the Mepis config tool FGLRX was very simple to get going. Thats where the praises ended. On a fresh boot it took up 350mb ram (Ubuntu takes 200), then with time that memory use went UP. After 3 hours of having Gaim and Firefox open, then i closed them so nothing extra was running, checked memory use again and it was 800mb. To me that says memory leak. An hour later I was at 900+mb.

to me that sounds

... like bollocks.... considering that Mepis uses ubuntu binaries for I guess 98% of the distro, and only ships a self-compiled kernel and a couple of utilities that are not loaded as services, a mepis specific memory leak is quite impossible.

On a fresh boot my 256 Mb laptop shows about 60% memory free, no swap used, you do the math... And it does not go up whatever I do.

On a 512 Mb desktop (with apache and Mysql running), having firefox and thunderbird open (and skype, gaim and some more gadgets) the system uses some 200 Mb. And stays that way. So either you have a buggy firefox extension or your system has become cannibalistic, but no way does Mepis consume 350 Mb on boot. No way!

Better then Kubuntu

I have tried many dists and I use more then one at home on different systems... but basically I just want to say that if i had to choose between Kubuntu and SimplyMEPIS 6.0... its a pretty easy choice...

They both have great things about them, but mepis just wins it for me... even tempted to wipe off my Debian etch install and run it on my main system, but i have put so much time into getting that Debian system running it would be a shame to kill it now... lol

If you like KDE and Debian based dists... this is the dist to use... unless your game enough to go for Debian... which i find to be very good, except for the hours and hours of tweaking involved

Dodgy Wireless support

I've been using the latest release of Mepis 6. It took a while to get multimedia codecs installed & working, but now my wireless card is sometimes seen, other times, not seen. Every time I boot up the PC, I have to manually stop wlan0 & re-enter my settings, then restart the network. Today Network informs me that wlan0 is running, but it can't see the card so I can't stop the network & restart it..!

Shame really, coz Mepis 3.4.3 worked perfectly, all other Distros don't recognise my network card (Dlink DWL 520+ PCI).

I had a few concerns as this was based on Ubuntu (that Distro can't even see my ATI graphics card, let alone my Wireless one).

WIFI

Did a reboot & it all worked OK. No problems with signal strength (always have an excellent signal both in Linux & Win XP).

I know that Mepis is still using Ndiswrapper with my PCI card (Dlink DWL 520+ based on ACX 111 chipset), it's just a little bit flakey sometimes whereas the older Mepis 3.4.3 was fine...

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

More in Tux Machines

A Seat at the Big Kids’ Table at Ohio LinuxFest

Ohio LinuxFest isn’t just another excuse to travel. It’s a means for us to fulfill ourselves, and to get honest, tangible feedback for what we do and for what others are doing. It’s a place where ideas are sounded, bent, crumpled and turned until they either come out of the crucible perfect…or useless. That’s what our gatherings are about. They are about excitement and promise. They​ are about making sure the next generation has a real chance to put the first human footprint on Mars. They are a chance to insure they have the tools and the curiosity to take something apart and then make it better. This next generation will cure diabetes; they will make cancer an inconvenience and not a death sentence. Read more

OpenStack Juno is out, Debian (and Ubuntu Trusty ports) packages ready

This is just a quick announce: Debian packages for Juno are out. In fact, they were ready the day of the release, on the 16th of October. I uploaded it all (to Experimental) the same day, literally a few hours after the final released was git tagged. But I had no time to announce it. This week-end, I took the time to do an Ubuntu Trusty port, which I also publish (it’s just a mater of rebuilding all, and it should work out of the box). Here are the backports repositories. For Wheezy: deb http://archive.gplhost.com/debian juno-backports main deb http://archive.gplhost.com/debian juno main For trusty: deb http://archive.gplhost.com/debian trusty-juno-backports main Read more

Video: Systemd the Core OS (no coughing)

There has been so much negative stuff about systemd on teh Interwebs lately. It is so sad. Quite a few distros picked systemd because they liked a lot of the features it has. Why do the people who like systemd actually like it? Sure, if you look hard enough, you can find those answers... but I remembered a video where the man himself explains it. Read more

GParted 0.20 Improves Btrfs Support

GParted 0.20.0 is out today with a release that primarily improves Btrfs support. The improved Btrfs support comes via now handling support for resizing Btrfs file-systems that span multiple devices. GParted 0.20 also has GRUB2 restoration steps added to the help manual plus various translation updates. Read more