Language Selection

English French German Italian Portuguese Spanish

Whoops: KDE fliccd Buffer Overflow Vulnerabilities

Filed under
KDE
Security

"Erik Sjölund has reported some vulnerabilities in KDE, which can be exploited by malicious, local users to gain escalated privileges and potentially by malicious people to compromise a vulnerable system."

"The vulnerabilities are caused due to boundary errors in fliccd and can be exploited to cause stack-based buffer overflows... in KDE 3.3 through 3.3.2."

Quoted.

No word from KDE on the subject as of yet.

More in Tux Machines

today's howtos

Ubuntu Replaces Its ‘Disintegrating Installer’ Icon with Something Simpler

Breaking news, right? Hardly. But this icon switch does rectify an issue that I publicly opined on before the release of Ubuntu 20.04 LTS. Back in March Ubuntu’s community-led design team decided to swap its discernible Ubiquity installer icon (below left) for what I described at the time as: “Ubuntu being sucked up a hoover”... Read more

Android Leftovers

Tails 4.11 is Out With Major Security Vulnerability Fixes

The Tails (The Amnesic Incognito Live System) team recently announced the release of their latest version, Tails 4.11 with several major security vulnerability fixes added on top the numerous security holes fixed in Tails 4.10. The Debian-based, live distro with the sole purpose of providing users with Internet anonymity by directing Internet traffic through the Tor network and at the same time, providing built-in tools for a secure work environment just received its latest release which has the primary focus of squashing bugs and toughening security. The distro has received fixes to numerous major security issues that existed in earlier versions and the developers strongly encourage users to upgrade their versions to the latest immediately. Read more