What you need to know about the SSLv3 “POODLE” flaw (CVE-2014-3566)